Home Forums Leads [Leads] Sparkpost for form submission notices

This topic contains 3 replies, has 2 voices, and was last updated by  Hudson Atwell 5 days, 13 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #129265

    mxwitkowski
    Participant

    Hudson,
    I have been working to setup InboundPro for our site and have come across an issue with sending admin notification emails on InboundPro form submissions. After I saw that InboundPro uses Sparkpost, I decided to move our site to Sparkpost plugin for all of our transactional email needs.

    I have setup and configured Sparkpost plugin on our site and am able to send a test email using the Sparkpost plugin. However, when I submit an InboundPro form and designate an admin email to get notices of the submission – no email arrives.

    In contrast, if I install and configure Sendgrid as the email plugin on our site, the InboundPro admin emails are delivered on form submissions without a problem.

    So, I think that there is potentially an issue when using the Sparkpost plugin on a site and sending InboundPro form submission notifications to administrators.

    Does this make sense to you? Anything I can do to further troubleshoot or help to find a resolve?

    Regards,
    Mark

    #129267

    Hudson Atwell
    Keymaster

    Hi Mark,

    It does. But I can’t confirm the issue on my side immediately because I’m certain Inbound Now’s website is under the same setup using SparkPost plugin to send normal WordPress emails and I am getting them in my email address.

    It might be that the admin email that is sending the wp core emails is not tied to a sending domain you have verified. But if test emails from the SparkPost plugin arrive then this should not be the case either.

    What I recommend doing is installing the email log plugin and then submitting an Inbound Form as checking the logs to see what they say, and what their from address says as well:

    https://wordpress.org/plugins/email-log/

    #129270

    mxwitkowski
    Participant

    Hudson,
    Good advice – I was able to troubleshoot further with the email log tool. What I found was that the setup of Sparkpost is strict when it comes to entering the ‘from email’ in the plugin settings page. While the field description says that the ‘from email’ field can be left blank to use a default verified domain – what I found is that you must put an enter an email address with a valid domain in the plugin settings page of Sparkpost.

    Once I put a domain valid email address in the ‘from email’ field, all is working just fine. Hopefully this resolve can help other users that are having the same issue.

    Thanks,
    Mark

    #129271

    Hudson Atwell
    Keymaster

    Very good.

    Thank you Mark.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.