Home Forums Landing Pages [Landing Pages] Mailing list sign up plugin reloads the page but no confirmation message

This topic contains 30 replies, has 2 voices, and was last updated by  Hudson Atwell 1 week, 3 days ago.

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #130918

    Hi !

    I’m using a plugin, called “Hype”, which gathers emails. The shortcode adds a simple email field and then displays a signup confirmation message.

    If I use it with Landing Pages plugin though, it doesn’t work. It does create the user (I found it in the database) but does not display the confirmation signup message (which it normally does, on the same URL), instead it just reloads the page the same way it was before, removing the email signup field.
    Now it should remove the email signup field but it should also add a signup confirmation text. Which means, if I am right, that it does remove what needs to be removed but fails to add what needs to be added ^^
    I deactivated all other plugins and tried with twenty seventeen only but same issue.

    I have this in the logs though :

    [14-Aug-2017 19:11:01 UTC] Database Error WordPress Table ‘truc.machin_2_inbound_page_views’ doesn’t exist for request SHOW FULL COLUMNS FROM ninja_2_inbound_page_views done by do_action(‘wp_ajax_nopriv_inbound_track_lead’), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, Inbound_Ajax::track_lead, Inbound_Events::store_page_view
    [14-Aug-2017 19:11:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /srv/data/web/vhosts/truc.domaine.com/htdocs/wp-content/plugins/landing-pages/shared/classes/class.ajax.php on line 79

    And in JS console, I get :
    TypeError: $(…).offset(…) is undefined[En savoir plus] testyooo:170:19
    <anonyme> http://truc.domaine.com/fr/go/testyooo/:170:19
    i http://truc.domaine.com/fr/wp-includes/js/jquery/jquery.js:2:27444
    fireWith http://truc.domaine.com/fr/wp-includes/js/jquery/jquery.js:2:28213
    ready http://truc.domaine.com/fr/wp-includes/js/jquery/jquery.js:2:30004
    K http://truc.domaine.com/fr/wp-includes/js/jquery/jquery.js:2:30366

    I’m really puzzled…
    Thanks for your help !! 🙂

    #130922

    Hudson Atwell
    Keymaster

    Hi Bernice,

    Welcome to the forums!

    Looks like there’s a database issue in one of your WP Multisite subsites. Log into your sub-site and run this repair to see if that fixes it. (http://docs.inboundnow.com/guide/repairing-broken-database-tables/) It should fix the error in your error logs but there is no guarantee that it will fix the issue with Hype plugin.

    If it doesn’t fix the confirmation, you could always send the submitter to a thank you page outside of the landing page. Also disabling split testing features from the settings area for landing pages might fix it as well.

    Kind regards,
    Hudson Atwell

    #130946

    Hi,

    thanks. 🙂

    It fixed the database error but the PHP error is still there :
    [14-Aug-2017 19:11:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /srv/data/web/vhosts/truc.domaine.com/htdocs/wp-content/plugins/landing-pages/shared/classes/class.ajax.php on line 79

    And this error is still present even without the hype shortcode, on the demo template provided by your plugin.

    How to fix ?

    #130948

    PS : on top of it, the A/B testing feature doesn’t work at all, it always gives the version A of the page (I emptied my cache, tried on different computers, and put “sticky variations” off)

    Here are the debug informations :

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multisite: Yes

    SITE_URL: http://subdomain.site.com/fr
    HOME_URL: http://subdomain.site.com/fr

    Landing Page Version: 2.6.1
    Upgraded From: None
    WordPress Version: 4.8.1
    Permalink Structure: /blog/%category%/%postname%/
    Active Theme: Twenty Seventeen 1.3

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    PHP Version: 5.6.30-5+0~20170223133305.27+jessie~1.gbp1ee0cb
    MySQL Version: Failed to connect to MySQL: Access denied for user ‘my_user’@’localhost’ (using password: YES)

    Web Server Info: Apache/2.4.25

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 128M
    PHP Post Max Size: 128M
    PHP Upload Max Filesize: 128M
    PHP Time Limit: 180
    PHP Max Input Vars: 2500

    WP_DEBUG: Enabled

    WP Table Prefix: Length: 8 Status: Acceptable

    Show On Front: posts
    Page On Front: (#0)
    Page For Posts: (#0)

    Session: Enabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /srv/data/var/php/www
    Use Cookies: On
    Use Only Cookies: On

    WordPress Memory Limit: NA
    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    – INSTALLED LP TEMPLATES:

    – ACTIVE PLUGINS:

    – NETWORK ACTIVE PLUGINS:

    Landing Pages :2.6.1

    ### End System Info ###

    Thanks!

    #130953

    Hudson Atwell
    Keymaster

    Hi the error you’re seeing there is a soft error and will be prevented in the next release. Will you disable WP_DEBUG to turn off soft errors?

    http://codex.wordpress.org/WP_DEBUG

    Also will you link to the landing page again for testing? And resave your permalinks and check the landing page in incognito mode to test split testing again.

    Kind regards,

    #130957

    Ok for the warning, I just wanted to let you know 😉
    My landing page is : http://ninja.beastof.com/fr/go/trop/
    I resaved permalinks and tested in incognito mode : bug is still there.

    Thank you,

    #130964

    Hudson Atwell
    Keymaster

    Confirmed. Still there. Will you copy the contents of your .htaccess file located in your base WordPress directory and paste them here?

    Somehow the redirect is not getting fired.

    Thanks for the updates, ttys,
    Hudson

    #130972
    This reply has been marked as private.
    #130973

    (PS : I put it as private reply as it may be sensitive information. Thank you)

    #130980

    Hudson Atwell
    Keymaster

    Thank you for the hand. It looks like our htaccess code is not making it in due to a conflict with WP Rocket, possibly.

    Your htaccess file should look something like this:

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteRule ^langing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Maybe it will work if we add these lines:

    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1  [QSA,L]
    RewriteRule ^langing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]

    directly under this line:

    RewriteRule ^index\.php$ – [L]

    it will work. Otherwise I recommend deactivating WP Rocket and resaving your permalinks to see if the regenerated htaccess looks like the one provided in the example above. At least then we can prove the conflict if it works after that.

    #130983
    This reply has been marked as private.
    #130993

    Hudson Atwell
    Keymaster

    The htaccess files should be generated automatically when your sub-sites permalinks are saved, so we are having to try manually for your case. Have you tried manually modifying the subsite’s htaccess file? I believe each sub-site has it’s own.

    Also, did you check for the WP Rocket conflict? It would be helpful to us to know why the htaccess rules are not getting generated properly. And if removing the plugin that is also, (heavily I might add), modifying the htaccess file solves our trouble.

    You could also try moving the WordPress block of your htaccess file, the block enclosed by # BEGIN WordPress, # END WordPress, to the top of your htaccess file. Sometimes that fixes htaccess problems.

    Kind regards,
    Hudson Atwell

    #131002

    Well no, there is only one htaccess for every subsite. It is a multi install which uses subfolders (and not subdirectories) but I assume this is the same thing for multi-installs with subdirectories.

    So I tried removing (not only deactivating) wp-rocket this time, and I also started with a “virgen htaccess” (which is the one provided with multi-installs by wordpress if I remember well). I also deleted Landing Pages plugin and reinstalled it again, and resaved permalinks (by the way, it didn’t ask for a database upgrade this time ??? And neither did it add anything to my htaccess file so I add to manually add your htaccess code myself).
    But the bug is still there…

    To try to debug I commented out some of the lines (as you can see in the code below), but bug is still there. So I assume this is not WP-rocket based but multi-install based right ?

    Also in the code you provided above there was a typo “langing-page” instead of “landing-page” but even with that typo it was working properly, weird 😛
    Would you kindly check that there is no other typo ?
    Thank you 😉

    So my htaccess right now is :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]

    RewriteCond %{QUERY_STRING} !lp-variation-id
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteRule ^landing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]

    # add a trailing slash to /wp-admin
    #RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    #RewriteRule ^ – [L]
    #RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    #RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    #131003

    PS : I See two possibilities :
    1) it is a bug related to the fact that there is a /fr added for every page of the 2nd subsite, so maybe something to do with url rewrites
    2) it is a deeper bug related to the fact that Landing Pages only sees the main site of the multi-install and not the others

    Thanks for your help

    #131008

    Hudson Atwell
    Keymaster
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 31 total)

You must be logged in to reply to this topic.