Home Forums Developers’ Hangout [Developers’ Hangout] Error when updating or install extensions

This topic contains 5 replies, has 2 voices, and was last updated by  Hudson Atwell 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #128994

    bram_1676
    Participant

    Hi Hudson,

    I am having real problems when updating Inbound Pro or want to install an extension.
    Can you please help me with this.

    This is the error message:

    Warning: tempnam(): open_basedir restriction in effect.
    File(/tmp) is not within the allowed path(s): (/usr/share/php/:/var/www/domains/bazoon.nl/) in /var/www/domains/bazoon.nl/www/wp-content/plugins/inbound-pro/classes/admin/class.updater.php on line 365 Warning: fopen(): Filename cannot be empty in /var/www/domains/bazoon.nl/www/wp-content/plugins/inbound-pro/classes/admin/class.updater.php on line 368 Warning: fwrite() expects parameter 1 to be resource, boolean given in /var/www/domains/bazoon.nl/www/wp-content/plugins/inbound-pro/classes/admin/class.updater.php on line 369 Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/domains/bazoon.nl/www/wp-content/plugins/inbound-pro/classes/admin/class.updater.php on line 370 Error : PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ” Warning: mysqli_query(): MySQL server has gone away in /var/www/domains/bazoon.nl/www/wp-includes/wp-db.php on line 1877 Warning: mysqli_query(): Error reading result set’s header in /var/www/domains/bazoon.nl/www/wp-includes/wp-db.php on line 1877

    #129004

    Hudson Atwell
    Keymaster

    Hi Bram,

    Will you contact your hosting provider and ask them to disable open_basdir restriction? They should be be able to help you if you show them the error message.

    #129020

    bram_1676
    Participant

    Hi Hudson,

    I contacted the hosotingprovider.

    They told me you are using a general “/tmp/” on the server.
    Since I am using a shared hosting they do not allow to use this general “/tmp/” .
    Instead I should use a tmp folder located in my hostingpackage.
    For instance: var/www/domains/bazoon.nl/tmp/

    Can this be achieved via settings??
    Or can I (or you) change this somehow myself.

    I don’t want to switch hostingprovider, have sevarela websites and client websites running with them AND will have more clients WITH Inbound Pro.
    (This week 2 new clients and more to come, and I prefer to use our current hostingprovider for those clients too)

    Thanks
    Bram

    #129028

    Hudson Atwell
    Keymaster

    Hi Bram,

    Try this, go into /plugins/inbound-pro/classes/admin/class.download-management.php and find line 221 and replace it with this:

    $temp_file = tempnam(sys_get_temp_dir(), 'TEMPPLUGIN' );

    It worked with my tests, it might work for your case too.

    #129245

    bram_1676
    Participant

    Hi Hudson,

    This worked. Thanks.

    I assume I have to make this change after every update in order to make it work for the next update. Since it overwrtites the previous replacement of ine 221.

    Can this be solved somehow?

    Thanks
    Bram

    #129258

    Hudson Atwell
    Keymaster

    Hi Bram,

    The change is already in the latest release files so you should be okay.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘[Developers’ Hangout] Error when updating or install extensions’ is closed to new replies.