Home Forums Calls to Action [Calls to Action] Call to action (form) is not working, the submit button is not reacting

This topic contains 12 replies, has 2 voices, and was last updated by  Frans Stoffels 2 weeks, 5 days ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #131917

    Frans Stoffels
    Participant

    We are using Inbound pro and have a license.

    Call to action (form) is not working properly, the submit button is not reacting!!

    I made a form in “Inbound form” and put the shortcode in a “call to action” page.
    This all shows in a widget “Call to action static widget
    When sending (submit) the form, this is not responding, so I can not sent.

    Please help me and let me know what to do.
    If you want I can sent you inlog credentials.
    Hope to hear

    #131922

    Hudson Atwell
    Keymaster

    Hi Frans,

    Would love to help. Will you link me to a page where the call to action is loading for testing?

    Kind regards,
    Hudson

    #131933

    Frans Stoffels
    Participant

    The call to action is a widget and showing on every page, except the homepage.
    This is such a page: http://hetkastenhuis.nl/tv-meubel-op-maat/

    I wil sent you some screens (3).

    IF you need the login, let me know.
    Regards.

    Attachments:
    You must be logged in to view attached files.
    #131940

    Hudson Atwell
    Keymaster

    Looks like it’s a rare conflict with the theme. I have a perma fix coded in my dev files that should be out soon.

    For a patch, try adding this to the CTA’s custom CSS:

    .cta-button {
        font-size:13px;
    }

    That may fix the issue.

    #131943

    Frans Stoffels
    Participant

    No effect, button still not reacting.
    I put the code, see my screen. Is that correct?

    And another question:
    Where can I change (in which file) the head H1 (BEL ME TERUG) into H2?
    The company who is doing the SEO is asking that.

    Attachments:
    You must be logged in to view attached files.
    #131949

    Hudson Atwell
    Keymaster

    Okay looking at the page again the code I provided you up above isn’t enough to fix it.

    This may provide a hot fix. Try adding this to the Custom JS metabox:

    jQuery('.cta-button').attr( 'id' , 'inbound_form_submit' );

    Alternatively you could apply the permanent fix manually:
    https://github.com/inboundnow/inbound-pro/commit/4159ff2231080293e6711f7382929dea3ca6c21f

    About the headlines, what template are you using?

    #131958

    Frans Stoffels
    Participant

    It worked after using: https://github.com/inboundnow/inbound-pro/commit/4159ff2231080293e6711f7382929dea3ca6c21f

    Should I still use the other codes (CSS and JS) you gave me?

    About the headlines.
    I only want to change the headline of the call to action form (BEL ME TERUG).
    The other H1 headlines should be as it is.
    I’m using the template “Seekr” from Themeskingdom.

    Hope to hear.

    #131969

    Hudson Atwell
    Keymaster

    If the patch worked then no need to apply the JS code or the CSS code.

    About the headline:

    \wp-content\uploads\calls-to-action\templates\form-skins-sarans-six-pack\index.php line 538.

    #131983

    Frans Stoffels
    Participant

    Thanks so far.
    I do not see where to change the headline exactly.
    – line 538 is a jquery
    – the index.php shows the smart green (h1), when changing this to (for example h2) it gives no effect.
    – the form itself shows a <h1> = $0
    I will sent some screens.

    What to do now?
    Thanks in advance.

    Attachments:
    You must be logged in to view attached files.
    #131988

    Hudson Atwell
    Keymaster

    Hi I think this screenshot will help:
    https://www.screencast.com/t/2GfK9VHFfVeR

    #131993

    Frans Stoffels
    Participant

    Great, thanks.
    Is there also a way to change only the head-line and not the subhead-line?

    Regards

    #131995

    Hudson Atwell
    Keymaster

    Try changing that line to this:

    jQuery(".{{form-class}} form").prepend("<div class='cta-2-headline'>"+headline+"<span>"+subheadline+"</span></div>");

    And add this to the index.php CSS code:

    .smart-green .cta-2-headline {
    	font: 24px "Trebuchet MS", Arial, Helvetica, sans-serif;
    	padding: 20px 0px 20px 40px;
    	display: block;
    	margin: -30px -30px 10px -30px;
    	color: #FFF;
    	background: #9DC45F;
    	text-shadow: 1px 1px 1px #949494;
    	border-radius: 5px 5px 0px 0px;
    	-webkit-border-radius: 5px 5px 0px 0px;
    	-moz-border-radius: 5px 5px 0px 0px;
    	border-bottom:1px solid #89AF4C;
    
    }
    .smart-green .cta-2-headline>span {
    	display: block;
    	font-size: 11px;
    	color: #FFF;
    }
    #131997

    Frans Stoffels
    Participant

    It is working now.
    Thanks for your great support.
    Regards Frans

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.