Home Forums Marketing Automation [Marketing Automation] Automation not triggering

This topic contains 15 replies, has 2 voices, and was last updated by  Hudson Atwell 1 week, 1 day ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #131818

    Pwerple
    Participant

    Hi there,

    WordPress 4.9 (says it’s the latest) Tried 2012, only inbound now(Version 1.8.5.1) and breadcrumbs(Version 5.7.1) still no triggers, log is empty
    was working until a couple of days ago.

    #131819

    Pwerple
    Participant

    Adding to a list triggers but not from the inbound form?

    #131820

    Pwerple
    Participant

    After adding manually to a list (under add users) it seems to clear the trigger blockage for want of a better word, but then
    inbound_form_id (230) equals 230 (match any) gives trigger error blocked with

    [filter_key] => lead_data:inbound_form_id
    [filter_compare] => equals
    [filter_value] => 230
    [compare_value] => notset
    [eval] =>

    Then the inbound form trigger is blocked until I add someone via a form and id then it clears again???

    #131821

    Pwerple
    Participant

    OK bad example, I know that equals needs the square brackets and contains doesn’t.

    Why when the trigger is add/update list and the condition is
    inbound_form_id (230) equals [230]
    Does the trigger filter evaluation say blocked with
    Array
    (
    [0] => Array
    (
    [filter_key] => lead_data:inbound_form_id
    [filter_compare] => equals
    [filter_value] => [230]
    [compare_value] => notset
    [eval] =>
    )

    )
    Where has the inbound form id gone?
    Why does the trigger not fire until I add a user via a form?
    What has changed?

    Thank you.

    #131822

    Pwerple
    Participant

    In case you need them here are the rule settings.

    WP_Post Object
    (
    [ID] => 232
    [post_author] => 1
    [post_date] => 2017-09-05 14:25:21
    [post_date_gmt] => 2017-09-05 14:25:21
    [post_content] =>
    [post_title] => 99 Days
    [post_excerpt] =>
    [post_status] => publish
    [comment_status] => closed
    [ping_status] => closed
    [post_password] =>
    [post_name] => 99-days
    [to_ping] =>
    [pinged] =>
    [post_modified] => 2017-11-28 09:01:13
    [post_modified_gmt] => 2017-11-28 07:01:13
    [post_content_filtered] =>
    [post_parent] => 0
    [guid] => http://goddessense.co.za/?post_type=automation&p=232
    [menu_order] => 0
    [post_type] => automation
    [post_mime_type] =>
    [comment_count] => 0
    [filter] => raw
    [settings] => Array
    (
    [trigger] => inbound_store_lead_post
    [trigger_filters] => Array
    (
    [1] => Array
    (
    [trigger_filter_id] => lead_data
    [trigger_filter_key] => lead_data:inbound_form_id
    [trigger_filter_compare] => equals
    [trigger_filter_value] => [230]
    )

    )

    [trigger_filters_evaluate] => match-any
    [action_blocks] => Array
    (
    [1] => Array
    (
    [action_block_filters_evaluate] => match-all
    [filters] => Array
    (
    )

    [actions] => Array
    (
    [then] => Array
    (
    [1] => Array
    (
    [action_name] => wait
    [action_class_name] => Inbound_Automation_Action_Wait
    [wait_time_hours] => 22
    [wait_time_minutes] => 0
    )

    [2] => Array
    (
    [action_name] => send_email
    [action_class_name] => Inbound_Automation_Action_Send_Email
    [send_to] => lead
    [custom_email] =>
    [email_id] => 227
    )

    #131826

    Hudson Atwell
    Keymaster
    This reply has been marked as private.
    #131837

    Hudson Atwell
    Keymaster

    So I’m looking at the rules and it seems there’s a lot of queued up tasks. That makes me think something’s wrong with the way automation tasks are processed. Has automation ever worked?

    When I tested onsite I tried to view all queue tasks and it seems to have crashed my access to the site. That might imply that this issue can be fixed by increasing server memory limits.

    Do you have access to your PHP error logs? It could be that we find a clue to what’s going on in there. If you can find them will you paste them here?

    I’d recommend disabling all automated rules except one until we can get the emails to start sending.

    ttys,
    Hudson Atwell

    #131840

    Pwerple
    Participant

    Hi Hudson,
    Yes automation has worked, stopped a few+ days ago.
    An automated WordPress update ran at about the time you were on last night our time. Then I did receive two of my tests, but same problems this morning. The log file was 200 Mb so attached is yesterdays log

    Attachments:
    You must be logged in to view attached files.
    #131845

    Hudson Atwell
    Keymaster

    I keep getting site crashes, so I’m thinking that whatever is crashing me, is crashing the automation system: https://www.screencast.com/t/ZW7zlJLCjiYx

    I also managed to see some errors in the PHP error log related to the Inbound Pro settings; in particular the field mapping settings. I’m locked out right now, will you check there and make sure those settings look normal and screenshot anything that is not normal.

    It could be that your hosting environment is very resource gated. At this point I’ve no clear solution, only leads. And the crashing keeps me from doing consecutive tests.

    #131849

    Pwerple
    Participant

    Thanks Hudson,
    I did wee in the fields a field key of I with a label of I which I deleted.
    I requested my hosting company afrihost.com to up my allocated memory which they did to 128Mb.
    When I queried still getting the error is the response I got

    Hello,

    We have already increased the memory limit to 128MB which is the maximum allowed value for this parameter in our shared server.

    So you need to contact a developer to optimize/compress the website inorder to avoid this memory limit issue further.

    Warm Regards,

    Reshma JAfrihost.com
    Pure Internet Joy!

    Is there anything else I can try from my side, what about a re-install but I don’t want to lose the 99days or 99days56 automation as they took a while to create.

    Kind Regards
    Paul

    #131850

    Pwerple
    Participant

    Hi Hudson,

    I stopped the 99 day 56 automation and the errors in the log stopped and I could add to 99 days automation, triggered, sent email etc.

    When I add a user and add them to a lead list it works, schedules but doesn’t send the email. In that lead list log it doesn’t have a task id, I don’t know if that means anything.

    In the php.error.log it says

    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 14103835 bytes) in /home/goddeemv/public_html/goddess/wp-includes/wp-db.php on line 1109

    That is the only error/problem I seem to be having now …

    #131851

    Pwerple
    Participant

    So it’s working from the inbound form now but not from the lead list.

    #131854

    Hudson Atwell
    Keymaster

    From looking at your rules it’s seeming the Automation component is being overloaded on the database connection side. Are you on a shared hosting package? Inbound Pro might not be a good fit as it takes procedures that are normally outsourced and tries to have WP handle it. I’m getting timeouts trying to load normal wp-admin areas. I looked at your queue and it did not look too large so there shouldn’t be timeouts. I’m not sure what’s going on.

    Your settings should stay there forever.

    https://www.screencast.com/t/eNlvAxsJktpe

    I think you’ll need to most likely power your email automation by a 3rd party service like mailchimp or aweber to offload the weight of automation/

    #131855

    Pwerple
    Participant

    Hi Hudson, I thought SparkPost was the 3rd party email service?
    It is the only drop down option in the Mail Service Setup menu in Inbound Pro.
    Is that where I should see MailChimp or should I select none and setup MailChimp elsewhere? Will it still use your automation?

    | Memory: 96 of 128 MB (75%) | WP LIMIT: 40 MB | IP 197.242.151.174 (tosen.aserv.co.za) | PHP 5.6.32 @64BitOS

    Do you have a link to help me with MailChimp?

    #131857

    Pwerple
    Participant

    FIXED

    OK found something.
    The WordPress default PHP memory limit is 64 Mb, even though my hosting company increased my shared server limit to 128 Mb it still only uses 64 Mb

    You need to edit the wp-config.php file to use more memory, the change is added right before the Last part of the wp-config.php file where it says “That’s all, stop editing! Happy blogging.”

    define( ‘WP_MEMORY_LIMIT’, ‘256M’ );

    /* That’s all, stop editing! Happy blogging. */

    I’m feeling very chuffed with myself because I’ve spent many days solid on this!

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.