Home Forums Account Management [Account Management] Api Key don't work

Tagged: , , , ,

This topic contains 30 replies, has 2 voices, and was last updated by  Hudson Atwell 4 months ago.

Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • #130800

    Hudson Atwell
    Keymaster

    Thank you for your report I’ll take this to our host and see if we can get a response on why this is happening.

    Kind regards,
    Hudson Atwell

    #130806

    Hudson Atwell
    Keymaster

    What is your servers IP address? They are going to try an access log lookup and they are going to try adding the IP to a whitelist.

    #130808

    nixadmin
    Participant
    This reply has been marked as private.
    #130814

    Hudson Atwell
    Keymaster

    Okay we whitelisted the IP. Will you check if it affects the behavior of the calls?

    #130827

    nixadmin
    Participant

    Unfortunately we have the same issue
    is there any more ideas to resolve this issue?

    Thanks

    #130838

    Hudson Atwell
    Keymaster

    Checked with support and they promise you’re not blocked and your IP is whitelisted. Unfortunately I don’t know how to solve this at this time. I can provide refunds if needed. In the mean time will you privately reply which host you are hosting with so I can mark a note and possibly perform further investigations?

    #130840

    nixadmin
    Participant
    This reply has been marked as private.
    #130842

    Hudson Atwell
    Keymaster
    This reply has been marked as private.
    #130845

    nixadmin
    Participant

    Hello.

    We rechecked it, the mod_security is not enabled on the server.

    Probably there are some another dependencies exist which can influent to remote access to https://www.inboundnow.com/pro-api/key/check/ ?
    As we still have the 403 error when try connecting to the remote server from wp admin panel.

    Thanks.

    #130853

    Hudson Atwell
    Keymaster

    What if you change the nature of wp_remote_post to wp_remote_get? (https://codex.wordpress.org/Function_Reference/wp_remote_get)

    If it doesn’t 403 then we’ve narrowed it down to POST requests.

    #130854

    nixadmin
    Participant

    Hello
    I have changed wp_remote_post to wp_remote_get and got same 403 nginx error

    #130861

    Hudson Atwell
    Keymaster

    What if you change the API URL to just https://www.inboundnow.com instead of the full API? And then change it to https://www.wordpress.org

    #130867

    nixadmin
    Participant

    Hello
    wp_remote_get and domain https://www.inboundnow.com

    
    *******
    nginx
    " ["raw"]=> string(305) "HTTP/1.1 403 Forbidden Server: nginx Date: Thu, 10 Aug 2017 13:41:37 GMT Content-Type: text/html Content-Length: 162 Connection: close
    403 Forbidden
    *****
    

    wp_remote_get and wordpress.org

    I see wordpress page on the top of the our website, it seems function is working correctly with any other website

    Let me know if you need more information

    #130874

    Hudson Atwell
    Keymaster
    This reply has been marked as private.
    #130890

    nixadmin
    Participant
    This reply has been marked as private.
Viewing 15 posts - 16 through 30 (of 31 total)

The topic ‘[Account Management] Api Key don't work’ is closed to new replies.